qualMeter XT update firmware #1 (Download Link)


Nope, SD card was inserted before. But it doesn’t make a difference. Still no updates.


I didn’t see your animation gif. How can I see it?


I have the video and will message you the link



I have our engineers studied your video. The video is too simple. It doesn’t really give much information. But we think this is likely connection problem, since you are so far the only one who is not able to upgrade. Could you make sure that your XT board is perfectly connected with the X mainboard through the 2x8pin connector? each pin is in its position and no bended pins? If everything seems to be fine after checking then it could be the XT board is defective (might be soldering issue).

Please let me know about your checking.



Hi, I have already removed the screws, checked pins and reconnected it still no difference. I connected a network cable to test and there is sound. But for normal USB cable and charger test there is no sound, probably due to the firmware being unable to update.


Here are images of the pins


Can I see the another piece? the XT. can you take a close up picture on the 2x8 female connector?


I’m also unable to update. I’ve even gone as far as removing the shield and connecting the board directly, and no luck. I manage to ruin one connector by plugging and unplugging, though. I’ve tried both versions of the firmware, and two or three different SD cards, including a new one. No luck. :frowning:



I normally don’t like to post “me, too” replies, but I am also unable to update.

I downloaded from the Google Drive with two different browsers on a Windows 10 machine. I have unzipped with two different programs. I inserted the card before power. I have tried two different SD cards with FAT32, 4 different chargers and very carefully checked the 2x8 pins on my shelled X. I even tried my 2nd X.

No sound from the buzzer at all (switch turned on and a cable plugged in).

Any more ideas?



The update was successful with a completely different Windows 7 computer, IZArc to unzip and a Kingston SD card instead of Sandisk. My suspicion is that the unit is very sensitive to the MicroSD card used. I will try my original setup (Win 10, etc.) with the Kingston SD card and update this reply with results.


Moin Moin,
So you will tell us that qoopow sold us a sd-card that will not work with their own hardware?


In my case, all of the SD cards were mine (used mostly in cameras). Qoopow didn’t send an SD card with my unit. To be fair to them, I have seen other devices that were sensitive to the manufacturer of the SD card.


@kitsura @jbernardo @schluej

I think @bassettg has found out the problem.

We have done a similar test on it these couple of days. The result shows that since the card slot on the XT board is controlled by a MCU, it’s a low level application, there is a compatibility issue with TF/SD cards. Most of the SD cards are ok with it, however, there are some of the SD cards which are indeed not able to be read on the XT with somehow unknown reason.

The reason that I could think of is it could be our SD cards are not branded (expensive) cards which might have compatibility issue with low level applications. We actually did one by one testing on the computer to make sure each card is a good card on its capacity and read/write capability. So the SD cards are definitely good for computer usage.

The solution is to find other TF/SD cards to try the update until you’ve got a right one. A branded SD card is recommended for this.

I truly apologies on what happened and the frustration it may have caused.



One of the cards I used is a 32GB sandisk, new from amazon… I’ll keep trying. Right now I’m afraid I damaged the socket by inserting and removing the XT, the same that I damaged one of the adapters, but I’m afraid of disconnecting to check in case I damage another adapter… :slight_smile:


Just to help everyone understand what worked for me and what did not:

Worked: Older Kingston 8GB HC Class 10 (but not UHS)

Did not work: Multiple new SanDisk Ultra 16/32GB, HC, Class 10, UHS-I 1

Sometimes older is better :-).


Just be careful :slight_smile:


Thank you @bassettg !:joy:

That really helps! :+1:


I think this is a really very weak excuse. I have tried 2 SD cards which were both older 1 4GB Toshiba and 1 2GB no brand card. How many more SD cards do i have to try to get it to work?


If anyone is still having issues downloading the Google Drive file I put an uncompressed copy on my web hosting here. (Which worked for me just fine with a 16GB Sandisk branded MicroSD)


And FYI if you don’t trust the link use Virustotal.com on the file! Better safe than sorry! :smiley: