qualMeter XT update firmware #1 (Download Link)


having the same issues here, no matter what i try the meter never updates


Unfortunately I must add a “me too”. I’ve tried a few times, reformatted the sd card, did different downloads, used “pure” usb chargers and PC USB ports, and nothing.
I can see the green led in the expansion board is on, but the update never seems to be applied.


I forgot to add, I have the shielded qualMeter X. Which do you guys have? Is this failure to update only on the shielded?


Same here. After connecting the expansion and downloading the firmware update onto an SD card the update just doesn’t want to seem to happen. The cable test runs immediately without delay. There is no sound and i have checked that the switch is in “on” mode.


Hi. I expierenced also the same. So it look like that many people made the same error OR the update file is not working. I have the qualmeter X with the plastic case. The charger test runs immediately without delay. There is no sound and i have checked that the switch is in “on” mode. Micro SD card have FAT32.


I suspect the firmware uploaded to Google is corrupted. Size is only 26k not 260k. Which is why it is not getting updated.


Could be. I’m also from the download of Google and repeated steps without working.

Is the file supposed to be 26k because both are…

[Edit] You mention 260k but both files I downloaded, one from the original site that we were concerned about security as well the Google download are identical in size and content from what I can gather. I will try to do a WinDiff on them but if the files is to be 260k; it’s not.


OK so not sure but it’s playing tones… Is this proof positive it’s flashed?

I believe mine is … working? I get the audible tones and the flashing LED’s under what appear to be the 4 sets of twisted pairs and does a low tone, then a counting up in freq tone like a ‘Do La Ra Me Da!’ It continues and if either power off it stops. Power back on, same thing.

I did use the original firmware .BIN from the very first download so I’m not sure if adding it from Google again, putting the card in and powering up would reflash or not but I can try to see if the Google one is bad maybe? Hmm…


So my suspicion is correct the google bin file is corrupted.


@schluej @kitsura @Ictinike @alexh71 @jbernardo @Magno99900 @Tarcs

Okay Guys,

We’ve created a new bin file and zipped it before uploading. Now it’s a zip file. You’ll need to unzip it first before the update.

Try it out! Let me know if it works or not.

BTW, Based on the fact that not all of you are having problem. So the BIN file itself should be ok. Otherwise everyone should have the same problem as you. I guess the file could be currupted during the downloading or might be altered by your computer for somehow reason (maybe anti-virus or firewall, etc?). Now, I’ve zipped it to put a shell on the file. Hope it can solve this problem.


The bin file is 26.29KB (27K to see in the windows), never 260K.


Just tried the zipped file and it now works for me, thank you.


@Jack Now the only issue I have! :slight_smile: Have to find me a new clamshell for storage to keep her nice and pretty!


I have reformatted my SD card, redownloaded the zip file and still i am unable to update the firmware. No sound for me.


Ok, this time it’s fine. Beep, beep … Thank you!


Hmm, this is very strange since other Angels seemed ok with the file now. Did you format with FAT32? Using Windows? Unzipped the file?..

It’s difficult to me to diagnose your problem. I guess I need more details. Any picture or video would be perfect.



That’s something we didn’t expect. :joy:


This is the image of the SD card with bin file inside. I have attached the animated gif of the tester running. There is no pause after SD card is inserted. So no sound during the tests.


It doesn’t beep without the other half and a cable attached.

So we think you have the firmware on SD and inserted. Place a network cable in the jack and the other end in the other transmitter with battery. Ensure the transmitter switch is in the ON position and then plug in the Qualmeter X with the XT board now attached. If it doesn’t beep, turn the ON switch on the Qualmeter X now with XT board.

IE: Mine does the same thing on the Qualmater without having a cable and the transmitter attached. I can try to get an animated GIF or a movie up for you if you want.


It seems you insert the SD card after you plugged the XT into the USB power? You should insert the SD card before XT was powered up.